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Section 1 Safety Precautions
Safety instructions

 Please read and follow these safety precautions when installing, operating, or maintaining
the product.

 For personal and equipment safety, please follow all safety precautions described in the
markings and manuals on the product when installing, operating, and maintaining the
product.

 The "Caution", "Warning" and "Danger" items in the manual do not represent all safety
precautions to be observed, but only in addition to all other safety precautions.

 This product should be used in an environment that meets design specifications, otherwise it
may cause a malfunction due to failure to comply with the relevant safety precautions.

 The product quality warranty does not cover abnormal function or damage to parts caused
by the regulations.

We will not bear any legal responsibility for personal safety accidents and property damage
caused by illegal operation of the product.

Security Level Definition

Danger

Indicates a potentially hazardous situation which, if not avoided,
could result in death or serious injury. Additionally, there maybe
severe property damage.

Caution

If not used in accordance with the regulations, may cause fires, serious personal
injury, or even death!

Warning

Failure to use in accordance with the regulations may result in moderate personal
injury or minor injury, as well as the occurrence of equipment damage!

When products arrive and are stored

Warning

 If the product and product accessories are damaged when opening the box,
please do not install them and contact our company or your supplier
immediately.

 Check carefully whether the arriving product and the ordered product model
match, and whether the product and product accessories are included.

Caution

 Do not stack multiple of this product on top of each other as this may cause
injury or malfunction.

 Do not store in places exposed to direct sunlight, places where the ambient
temperature exceeds the temperature conditions for storage, places where
the relative humidity exceeds the humidity condition for storage, places
where there is a large temperature difference, places where there is high
condensation, places near corrosive gases, places where there are
flammable gases, places where there is a large amount of dust, dirt, salt or
metal dust, places where water, oil or medicine drip, places where vibration or
shock can affect the main body of product; otherwise it can lead to fire,
Electric shock or machine damage.

 Do not hold the cable or motor shaft for weight holding, as this may result in
injury or malfunction.

When designing the system

Danger

 If the rated load of current is exceeded or the load is short-circuited for a long
period of time resulting in over-current, the product may start smoking or
catch fire.

 Safety devices such as fuses, or circuit breakers should be set externally.
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Warning

 Be sure to design safety circuits to ensure that the product system will still
work safely if the external power supply is lost, or the product fails.

 For safe operation of the equipment, please design external protection circuits
and safety mechanisms for output signals related to major accidents.

Caution

 Be sure to install emergency brake circuits, protection circuits, interlock circuits
for forward and reverse operation, and position upper and lower limit interlock
switches to prevent damage to the machine in the external circuit of the
product.

 The product may shut down all outputs after detecting abnormalities in its own
system; when part of the controller circuit fails, it may cause its output to be
uncontrolled. To ensure normal operation, a suitable external control circuit
needs to be designed.

 If the output unit such as relay or transistor of the product is damaged, the
output will not be controlled to the ON or OFF state.

 The product is designed to be used in indoor, overvoltage class II electrical
environments, and its power system level should have lightning protection
devices to ensure that lightning overvoltage is not applied to the product's
power input or signal input, control output and other ports to avoid damage to
equipment.

When the product is installed

Danger

 Only maintenance professionals with adequate electrical knowledge and
training related to electrical equipment should install this product.

 For the product with open equipment, please install in the control cabinet with
door lock (product cabinet shell protection > IP20), only operators with
sufficient electrical knowledge and training related to electrical equipment can
open the product cabinet.

Warning

 When disassembling the product, the external power supply used for the
system must be completely disconnected before performing the operation.
Failure to disconnect all power supplies may result in electric shock or
product failure and malfunction.

 While dissembling the product, the power and the power indicator must be
turned off for at least 5 minutes, before disassembling the driver. Otherwise,
the residual voltage may cause electric shock.

 Do not use the product in the following places: places with dust, oil fumes,
conductive dust, corrosive gases, combustible gases; places exposed to high
temperature, condensation, wind, and rain; places with vibration and shock.
Electric shock, fire, and misuse can also cause damage and deterioration of
the product!

Caution

 Avoid metal shavings and wire tips falling into the ventilation holes of the
product during installation, this may cause fire, malfunction, and
misoperation.

 After installation, ensure that there is no foreign matter on the ventilation
surfaces, otherwise it may lead to poor heat dissipation and cause fire,
malfunction and misoperation.

 When installing, make a tight connection to the respective connector and lock
the product connection hook firmly. If the products are not installed properly, it
may lead to misoperation, malfunction and dislodgement.

When wiring products

Danger

 Only maintenance professionals with adequate electrical knowledge and
training related to electrical equipment should perform the wiring of this
product.
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Warning

 During wiring operations, the external supply power used by the system must
be completely disconnected before operation. Failure to disconnect all of
them may result in electric shock or equipment malfunction or misoperation.

 When powering up and running after the wiring operation, the terminal cover
that comes with the product must be installed. Failure to install the terminal
cover may result in electric shock.

 Check the type of interface to be connected before connecting the cable
correctly. If the wrong interface is connected or the wiring is incorrect, it may
cause the product or external equipment to malfunction.

 The cable terminals should be well insulated to ensure that the insulation
distance between the cables is not reduced after the cables are installed to
the terminal block. Otherwise, it will lead to electric shock or equipment
damage.

 Avoid metal shavings and wire tips falling into the ventilation holes of the
controller when wiring, which may cause fire, malfunction, and misoperation!

 The bolts on the terminal blocks should be tightened within the specified
torque range. Untightened terminal bolts may result in short circuit, fire, or
malfunction. Over-tightening the bolts may damage the bolts and the product,
resulting in dislodgement, short circuit, fire, or false operation.

Caution

 The specification and installation method of the external wiring of the
equipment should meet the requirements of local power distribution
regulations.

 To ensure the safety of the equipment and the operator, the equipment needs
to be reliably grounded using cables of sufficient wire size.

 For connections using connectors and external devices, press fit, crimp, or
properly solder using the tool specified by the manufacturer. A poor
connection may result in a short circuit, fire, or malfunction.

 If the product is labeled to prevent foreign objects from entering the product
during wiring, such as the wiring head. Do not remove this label during wiring
operations. Before starting system operation, be sure to remove the label to
facilitate heat dissipation.

 Please do not bundle the control and communication cables with the main
circuit or power supply cables, etc. The alignment should be more than
100mm apart, otherwise the noise may lead to misoperation.

 For applications with serious interference, please use shielded cables for input
or output of high frequency signals to improve the system's anti-interference
capability.

Before powering on the product

Danger

 Before powering on, please make sure the product is well installed, wired
firmly and the motor unit is allowed to restart.

 Before powering on, please confirm that the power supply meets the product
requirements to avoid causing damage to the product or starting a fire.

 It is strictly forbidden to open the product cabinet door or product protective
cover, touch any terminals of the product, disassemble any device or parts of
the product in the energized state, otherwise there is a risk of electric shock.

 Make sure that no one is around the product, the motor, or the machinery
before powering it on, as this may result in injury or death!

Warning

 After the wiring operation and parameter setting are completed, please
conduct a test run of the machine to confirm that it can operate safely,
otherwise it may lead to injury or equipment damage!

 Before powering on, please make sure that the rated voltage of the product is
the same as the power supply voltage. If the power supply voltage is used
incorrectly, there is a risk of fire!
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When operating and maintaining

Danger

 Only maintenance professionals with adequate electrical knowledge and
training on electrical equipment can perform the operation and maintenance
of the products.

 Do not touch the terminals when the power is on, as this may cause electric
shock or malfunction.

 When the motor or equipment is running, please never touch its rotating parts,
otherwise it may lead to serious personal safety accidents.

Warning

 When cleaning the product or retightening the bolts on the terminal block or
the connector mounting bolts, the external supply power used by the system
must be completely disconnected. Failure to do so may result in electric
shock.

 When disassembling the product or connecting or removing the
communication cable, the external supply power used by the system must be
completely disconnected first. Failure to disconnect all of them may result in
electric shock or false operation.

 While dissembling the product, the power and the power indicator must be
turned off for at least 5 minutes, before disassembling the driver. Otherwise,
the residual voltage may cause electric shock.

Caution

 For online modification, forced output, RUN, STOP, etc., you must read the
user's manual and confirm its safety before performing the relevant
operations.

 Be sure to disconnect the power before loading and unloading expansion
cards, modules, and other components!

When the product is scrapped

Caution

 Please dispose of them as industrial waste; when disposing of batteries, do so
separately according to the ordinances established by each region to avoid
property damage or human injury!

 End-of-life products should be treated and recycled in accordance with
industrial waste treatment standards to avoid polluting the environment.
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Section 2 Overview of HMC and Codesys

2.1 Overview of HMC
HMC series industrial controller is an industrial grade controller (hereinafter referred to as

HMC) that combines PLC functions, motion control functions, robot control functions and
machine vision functions to provide users with intelligent automation solutions. HMC series
controller adopts IEC61131-3 programming language system and supports PLCopen standard 6
programming languages. It can communicate with servo systems, IO modules, etc. at high speed
via EtherCAT bus, and can also expand machine vision applications and interconnect with
remote monitoring terminals and demonstrators. High-performance motion control functions can
be implemented through EtherCAT bus; single-axis acceleration and deceleration control
function, electronic gear function, electronic cam function, and single-axis basic positioning
function can also be implemented through high-speed IO; RS232, RS485, Ethernet, USB and
other communication functions are also supported to meet the diversified application needs of
users.

2.2 Codesys Overview
Codesys is the PLC programming software of Germany Codesys Group, also used for the

development application of HMC series controller products standard software. It provides a
complete configuration, programming, debugging, monitoring environment for HMC serial
controller. It uses flexible, free, and powerful IEC language.

The management of projects and devices can be done through Codesys, providing the
following configuration options for the HMC series:
 EtherCAT bus configuration.
 SoftMotion CNC+Robotics functional configuration.
 TargetVisu configuration.
Functions such as writing, downloading, and debugging of programs can be accomplished,

and provide the programmer with the following facilitates:
 Standardized programming (according to IEC 61131-3).
Support for all six programming languages: Structured Text (ST), Function Block Diagram

(FBD), Instruction List (IL), Ladder Diagram (LD), Sequential Function Chart (SFC) and IEC
61131-3 Extended Programming Language Continuous Function Chart (CFC).
 A flexible library of functional blocks.
 Easy configuration of task calls.
 A comprehensive library of functional blocks and support for user-defined libraries.
 Off-line simulation functions.
 Complete program debugging and simulation without the need to connect PLC

hardware.
 Intelligent debugging and error checking functions.
 Pre-compilation and compilation error checking, quick location of programming errors,

diagnosis, and logging.
 Sampling tracking.
 Timing diagrams of process variables are created.
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Section 3 Configuring the Codesys
Programming Environment

3.1 Codesys software acquisition and installation
requirements

3.1.1 Software acquisition
 Contact AUCTECH Technologies to provide a Codesys software installation package that is

compatible with the controller system version (recommended).
 Go to the Codesys official store at https://store.codesys.com to download the specified

version of the software.
 Note: Download the appropriate version of 64-bit or 32-bit software according to your

computer system version.

3.1.2 Software installation requirements
PC meet the following requirements:
 Window 7/Windows 8/Windows 10 operating systems.
 CPU: higher than 2GHZ (recommended).
 Memory: 4GB or higher.
 Space: 10G or more of hard disk space.
 Connection requirements to the controller: 1 free network port on the local network or via

USB to network adapter (with anti-electromagnetic interference).

3.2 Codesys Software Installation
3.2.1 Pre-installation preparation
The first installation can be installed directly.
Update from old version, please backup the existing work files first, uninstall the old version and

reboot the computer before installing the new version of the software.
3.2.1.1 Start installation

1) Turn off antivirus software to prevent antivirus software from accidentally deleting necessary
components.

2) Open the directory where the installation file is located and double click to open the
Setup_CODESYSV(XXX).exe file.

3) Double-click to open it and start the installation, the following prompt will appear, click "Next"
to prepare to start the installation.
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4) Check "Accept" to agree to the installation terms and click "Next" to continue the installation:
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5) set the software installation path, click "Next", go to the next step:

6) enter the installation component selection interface, select "Complete" to install all
components, click "Next" to continue:

7) Follow the wizard prompts to complete the installation and you will see the Codesys icon
on your desktop.
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3.3 Installing the device description file
Installing a device description file is an operation that needs to be done when a user adds or

removes hardware device information.
The device description file contains the name, vendor name, category, version, and device

description of the device; the device library is the database of the device, and all data from the
device description file installation is imported into the user's local system device library for use in
CodeSys development programming.

For example, to use the HMC controller, you need to install the controller device description file
provided by AUCTECH.

 The device description file is installed as follows:
1) Click "Tools" → "Device Repository" → "Install", as shown in the following figure:

2) Select the device description file (*.xml) of HMC controller in the pop-up window → click
"Open", as shown in the following figure

3) The message shown below pops up to indicate successful installation of the device
description file:
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Section 4 Library Files
4.1 Library Overview

Library files are used to store functions, function blocks, procedures, specially defined structures,
enumeration types, etc. that can be reuse in Codesys. These POUs can be copied from existing
projects into the library, or the user can directly create a new library project and define the library in
the project itself. This can save a lot of programming time and increase efficiency if the library under
Codesys contains function blocks, functions, or procedures that the user wants to call more than
once. The default function library file is ".library*", while the encrypted library has the extension
“*.compiled-library”. The encrypted library cannot be opened directly to get its source code but can
be called all functions and function blocks in the library normally.

 The standard library files are already included in the Codesys standard package, as shown
in the figure.

4.2 Library management
If you want to install the library files on your computer or call the library files provided by your

supplier, you need to use the library file management. Library file management is defined by using
the menu command "Tools" → "Library Repository", as shown in the figure for the library file
management view.

4.3 Calling library files
After installing the library file, you need to add the library file in the project to call the function or

function block, etc. Then you need to use the library manager to achieve this function, the specific
steps to add the library call:

1) Double click "Library Manager" in the project → click "Add Library" → click "Advanced" to
select the previously installed library files in the Library Manager, as follows:
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2) users can select the classification according to the vendor name, library function and version
number, as follows:

3) In the following figure, the selected library is added to the library manager, you can use the
function blocks or functions provided in the library in your project. Select the library, you can
see the function or function block provided in the library, select it to see the relevant
parameters and description documents, as follows:
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Section 5 Package acquisition and installation
A package (*.package) is a collection of library files, help files, device description files, Codesys

software components, etc. The installation of a package allows you to install all the files required for these
functions at once.

5.1 Package acquisition

5.1.1 Get the latest Codesys Feature Pack in the official Codesys

store
There are many packages available in the Codesys official store, some of which require payment and

there are also many free example packages of features that can be used to learn how to use Codesys
features.

5.1.1.1 To download the package from the official Codesys store, proceed as follows:
1) Open the Codesys official store at https://store.codesys.com , as follows:

2) For example, if you need to use shared memory-related functions, you can search for the
"share" keyword, as follows:

3) You can see all the related packages according to the keyword, Shared Memory is the
sample package that we need to shared memory, click into it to download (login required).
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5.2 Package installation

5.2.1 Package installation method:
1) Click "Tools" → "Package Manager" or "CODESYS Installer"→ "Install", as follows:

2) Select the local package file in the pop-up folder, as shown in the following figure:

3) Just follow the installation wizard to complete the installation.
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Section 6 Quick Start

6.1 Starting the programming environment
1) Double-click the desktop Codesys software icon to start the programming software and enter

the software start screen.

2) Click Tools (Tools)→Options (Options)→Language Settings (International Settings) →Set
the language as needed.

6.2 Creating Application Projects
1) click the upper left corner of the new project or "File" → "New Project", select the project type,

project file name, and save path, as follows:
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2) After clicking OK, enter the standard project interface and select the device type
corresponding to the current controller (please refer to Section 2.3 Installing Device Description File
for installing the corresponding controller description file) and programming language. As following
figure:

3) at this point, click "OK" to enter the system configuration and programming interface. The
usual distribution of buttons and windows as follows:
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Section 7 Writing Applications

7.1 Steps to write an application
A complete user program must be written and debugged in 5 steps, which first time users of HMC

need to pay attention to.
1) The hardware configuration is based on the HMC hardware connection. If a network bus is

used, the corresponding bus slaves need to be configured according to the bus connection order.
2) Writing user programs according to the control process of the application system.

Programming user programs to define variables according to the type of data, the range of use,
which can be independent of the hardware configuration.

3) Associating the input port variables (I), output states (Q) or values (M) corresponding to each
hardware port in the system's composition with the variables in the user program.

4) Configuration of the synchronization period of the network communication (e.g., EtherCAT
bus) and of the execution period of the user program units according to the real-time requirements.

5) Under the Codesys programming environment, log in to HMC, download the user program,
simulate commission, and troubleshoot until it runs correctly and without errors.

7.2 User application programming
Double-click the "PLC_PRG(PRG)" item in the tree window on the left to open the user programming

interface, the programming language is ST (selected when creating a new project), as shown in the figure
below. Like C language, each variable needs to be declared before it can be used, if you write the
program statement directly first, when you enter, the programming environment will automatically pop up
the declaration box for the user to fill in, once you click "OK", the variable declaration window will
automatically add the declaration statement of the variable, which simplifies the programming:

 Write a simple example that implements a circular count of a integer variable, as follows:



HMC Serial Software Getting Started Manual Section 7 Writing Applications

17

7.3 Configuring the execution method and operating cycle of

user application
In the task configuration, you can see that PLC_PRG is called under MainTask by default, double

click MainTask to enter the task setting interface, you can see that the default is executed periodically
every 4ms, if you want to change to other execution methods, such as repeated execution, timed
execution, execution period, etc., you can set them separately, as follows:

7.4 Compilation of user application
After the above programming, compile the user application and check if there are any errors. If there

are errors, click on the error message line to locate the error reporting point of the user program for easy
modification until all errors are eliminated. The relevant compilation information will be displayed in the
following compilation information box, as follows:

7.5 Login and download to HMC
"Logging into HMC means running the Codesys environment on a PC and establishing a

communication link with HMC to download, start and stop user programs, monitor the operation of
user programs, view or modify parameters, etc. At present, you can log in to HMC through LAN, and
you can connect directly between PC and HMC through network cable, or through router or hub, in
this case, you can connect one PC to multiple HMCs, or multiple PCs can access the same HMC;
the IP address of PC and HMC must be the same network segment by default in order to log in to
HMC. For example, the factory default IP address of HMC is 192.168.1.92, if the IP address of PC is
192.168.1.xxx, (here xxx means 1~254 range, but don't have the same IP address as the HMC),
then Codesys can scan HMC, and interact with it for user program download, operation monitoring,
etc. If the IP address of HMC has been artificially modified, and its address is not in the IP address
network segment where the PC is located, the PC local address can be changed to the same IP
network segment address as the HMC.
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1) PC can log in to HMC controller through LAN network as follows:
a. In the Codesys environment, double-click the Device to bring up the following screen:

b. On this screen, mouse click on the "Scan network" tab, the following screen will pop up,
and the HMC controller will be found

(See Section 4.2 for devices not scanned), click on the name of one of them on the left side
of the window, and on the right side of the window you can see its profile information:

2) controller was found in the above figure:
IPC-YDD is the name of the device, the last 2 digits of the number in brackets "5C" is the 4th

segment of the IP address of the PLC, which is displayed in hexadecimal and converted to decimal as 92.
Now double-click the selected device or select the device, and then click "Confirm " to activate the
connection between the host computer and the current device. If the controller identification number
registered in the current project does not match with the selected controller, you may see a reminder
message, if you want to connect, click "Yes" button to confirm.

3) After compiling, click "Online" - "Login to", as follows:
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4) The host computer successfully downloads the project to the device, and the initial status is
"Stop", as follows:

5) Click "Debug" → "Start", the device enters the running state and starts to execute the user
program.
The following image shows the monitoring screen of a running user program:
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Section 8 EtherCAT Bus Configuration

8.1 Adding an EtherCAT Master
1) On the main screen of Codesys, right-click on "Device" in the tree window on the left, and

click on "Add Device" in the pop-up menu option, as shown below:

2) In the pop-up window, select: Fieldbus → EtherCAT → Master → EtherCAT Master
SoftMotion, click on the "Add Device button", as shown below:

3) Once completed, an EtherCAT master can be added to the device tree.
Double click on the master to open the master configuration interface, click on the "Browse"

button and select the NIC used for EtherCAT communication in the pop-up window, e.g., the default
name of the HMC factory EtherCAT NIC is Ethercat, then select Ethercat in the window.
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8.2 Adding a Servo Drive Slave
1) Right-click on the main station and click "Add Device" in the pop-up menu option, as shown

in the following figure:

2) in the pop-up window to select the type of driver to be added, such as this example, select
the Auctech servo driver, click "Add Device" can be, as follows:
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3) Right click on the newly added slave and click on "Add SoftMotion CiA402 Axis" in the menu
options to add a drive axis. Use this method to add multiple slaves depending on the actual order and
number of bus connections.

4) Double-click the axis name to open the parameter setting interface of the axis, as follows:
Setting the type, direction, soft limits, motion parameters, etc. of the axis.
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5) Click on the mapping column of the axis, as follows:
Set the shaft drive ratio relationship as follows: the motor encoder resolution is 17 bits, the

gearbox drive ratio is 21:1, the gearbox output corresponds to the program unit ratio of 1:360, and
the user sets these parameters according to the actual hardware design parameters.
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Section 9 FAQ

9.1 Network connection checking between PC and HMC

9.1.1 Network environment checking
HMC: called the target machine, the factory default IP (192.168.1.92)
PC commissioning: called the host, assuming the IP is 192.168.1.55
The following operations can be performed on the target or host machine

9.1.2 Checking network connection
1) Open the Run window by pressing "Win" + "R" at the same time in the keyboard
2) Type the command "cmd" in the Run window

3) In the command window, type "ping" + space + IP address of the target machine, for example, the
known HMC address is 192.168.1.92, then in the command window type: ping 192.168.1.92, enter to

show whether the network is connected to:
As shown in figure①. "ping" + space + IP (in the target machine operation enter the host IP,

otherwise the opposite).
As shown in figure②, represent they are in the same network.
As shown in figure③, it means that it is not in the same network, you need to confirm the IP segment

in the target machine and the host machine
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9.1.3 Network failure check and configuration
1) Check whether the network cable is connected and whether the controller end is connected to

the ETH1 network port.
2) Enter the IP configuration query command "ipconfig" in the respective command windows of the

host and the target machine to ensure that both are in the same network segment in IPv4, for
example, the network segment in the figure below = 192.168.1, if the two IPs are not in the same
network segment, set the IP address to the same network segment.

3) IP address setting steps are as follows
The IP addresses of HMC and PC are set in the same way as follows:
Taskbar → Click "Computer icon" → Click "Open Network & Internet settings" → Ethernet → Click

"Change adapter options→Click”LAN2“→Click”Properties“button→ Select "TCP /IPv4 Protocol" → click
"Properties" button → Set Fixed IP (set IP address, subnet mask, gateway) → click "Confirm" button.

Note: As shown in step 7, the last paragraph of the IP address can be set arbitrarily, but the target
machine and the host machine cannot be the same, and the gateway and subnet mask must be set.
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(Figure 2)-2

9.2 Possible reasons for Codesys not scanning HMC devices
1) The network between PC and HMC is not connected, see 4.1 for checking.
2) Whether the Codesys gateway in the taskbar of the PC is open (displayed in color) and

started if it is Stop.

3) Whether the RTE of the controller is activated or not, the inactive HMC controller
automatically exits in 2 hours and cannot be scanned, requiring a restart of the HMC.

4) Check if the Device type in the Codesys project is the same as the controller, for example,
the device type of the HMC controller shows as follow:
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9.3 Missing Codesys library compilation error
1) when opening an existing project often appears the project reference library is not installed, resulting

in compilation errors, if the missing library for the Codesys library can be downloaded online by
clicking "Download miss libraries" to download the missing library, as following figure:

2) Open the "Download Missing Libraries" view and click "Download" to start downloading the missing
libraries:
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Section 10 Remote Desktop Usage and
Configuration

10.1 How to open HMC Remote Desktop
10.1.1 Set the user password to access
1) Open HMC system password, click "Search control panel → click "User Accounts" :

2) Click "Manage another account" → click “Administrator” → click “Creat a password”:

3) Enter the password in the input text box → click the "Create Password" button:
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4) Right-click on the computer icon → select "Properties" → click "Remote Settings":

5) Check "Allow remote connections to this computer" → Click the "Apply" button → Click the "OK"
button

Now, remote desktop control using the user password has been set up and can be accessed
from the host side.
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10.1.2 Access by empty password
1) Clear user password, if the factory defaults no password, please ignore this step.

To clear a password for a user, click the "Start" button → click the "User icon" → click "Change the
password" → enter the password in the input text box → click the "Change Password" button

2) Empty password setting:
Press "Win" and "r" at the same time on the keyboard to open the Run window → Type secpol.msc

command in the Run window → Local Security Settings → Security Policy → Local Policy → Security
Options → Accounts: Limit local account use of blank passwords to console logon only → Disable → OK,
as shown in the following figure:
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Now, the remote setting of the controller side without using the password has been completed.
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10.1.3 PC access HMC through remote desktop
10.1.3.1 Initiating access
Press "Win" and "R" at the same time → type "mstsc" in the Run window, press the Enter key →

enter the IP address of the target machine, click "OK" button.
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